Delivery of international letters may be delayed
Incident Report for GOV.UK Notify
Resolved
Royal Mail has resumed delivery to mainland Europe, Canada and Turkey.

International letters held at Royal Mail’s dispatch centre will now be delivered.

Letters to some countries may still be delayed because of coronavirus (COVID-19).

For more information, see the Royal Mail website: https://personal.help.royalmail.com/app/answers/detail/a_id/5317/~/international-incident-bulletin
Posted Jan 04, 2021 - 14:24 GMT
Update
We are continuing to monitor for any further issues.
Posted Dec 22, 2020 - 10:53 GMT
Update
We are continuing to monitor for any further issues.
Posted Dec 21, 2020 - 17:08 GMT
Monitoring
Delivery of international letters may be delayed

Royal Mail has suspended delivery to mainland Europe, Canada and Turkey. This is because of a 48 hour ban on UK freight, announced by the French government on Monday 21 December.

We recommend you do not send any international letters until the ban is lifted.

International letters sent on or after Friday 18 December may be delayed. Royal Mail will keep the letters at their dispatch centre until they can deliver them.

International letters sent on or before Thursday 17 December are not affected.

We apologise for the inconvenience the delays will cause for you and your users.

If you have any questions, please contact us using our support page: https://www.notifications.service.gov.uk/support.
Posted Dec 21, 2020 - 17:01 GMT
This incident affected: Letter sending.