API downtime
Incident Report for GOV.UK Notify
Resolved
We are now confident that the cause of this outage has been resolved. Everything has been working as expected since 16:20hrs - following a disruption to service of 34 minutes.

We estimate this disruption will have effected 540,000 requests to the API during this time, all of which would have failed, but been processed upon retry after the incident was resolved.

Access to the Notify web interface was also blocked between 16:10hrs and 16:20hrs while we worked to restore service.

The disruption was caused due to an upgrade from one of our providers, to increase capacity and apply a number of urgent security patches. We are working closely with them to make sure you aren't impacted by these kind of changes in the future.

We know this disruption will have caused you, and your users, hassle and concern. We are sorry for this. And be assured we take performance and availability incredibly seriously, as do our providers.

Thank you for your patience and understanding.

Pete
GOV.UK Notify
Posted Jun 24, 2020 - 19:15 BST
Update
All systems appear to be operating normally but we are still investigating to make sure we understand the root cause of this issue. We have seen no errors since 16:17 BST. We will continue to monitor the situation.
Posted Jun 24, 2020 - 16:46 BST
Monitoring
We think we have identified the cause of the issue and have made a change which we hope will fix this. The API and user interface appear to be returning to normal. We will update you shortly to confirm whether this has been successful.
Posted Jun 24, 2020 - 16:28 BST
Investigating
We are aware of a problem with the GOV.UK Notify API and user interface. We are currently investigating and will update you shortly when we are clear what the impact is.
Posted Jun 24, 2020 - 15:57 BST
This incident affected: API, File uploads, Text message sending, Text message delivery receipts, Text message receiving, Email sending, and Email delivery receipts.