Storm Goretti has disrupted UK postal services

Incident Report for GOV.UK Notify

Resolved

Following storm Goretti, the UK postal network has resumed normal service.

There were no further delays over the weekend.

Letters sent on Thursday 8 January were delayed by 24 hours.
Posted Jan 12, 2026 - 12:01 GMT

Monitoring

Weather conditions have disrupted Royal Mail deliveries across the UK.

Letters sent to GOV.UK Notify on Thursday 8 January may be delayed.

The postal network in the Midlands is experiencing more disruption than other parts of the country.
Posted Jan 09, 2026 - 10:53 GMT
This incident affected: Letter sending.