Slow delivery of text messages
Incident Report for GOV.UK Notify
Resolved
Our delivery providers have confirmed that the network issue with O2 was resolved around 9pm last night.

We have seen text messages getting delivered as normal since then.

GOV.UK Notify was working normally throughout this incident.
Posted Aug 03, 2023 - 09:44 BST
Update
We are still seeing a small percentage of text messages delivering slowly.

Our text message providers continue to work with the mobile network operators to investigate the problem.

GOV.UK Notify is working normally.

We will send a further update tomorrow morning.
Posted Aug 02, 2023 - 17:42 BST
Monitoring
There has been an issue with text message delivery across parts of the O2 network.

We are not currently aware of any issues with other UK mobile networks.

Our latest reports show that delivery rates have started to return to normal over the last 15 minutes, but we will continue to monitor.

GOV.UK Notify itself is working normally.

We will provide a further update if the situation changes.
Posted Aug 02, 2023 - 16:40 BST
Investigating
We are investigating reports of slow text message delivery, and slow confirmation of delivery.

This seems to be present across both of our text message providers, which may indicate a problem at the mobile network level.

We will provide a further update within the hour.
Posted Aug 02, 2023 - 15:45 BST
This incident affected: Text message sending and Text message delivery receipts.