Lebara degradation

Incident Report for GOV.UK Notify

Resolved

This incident has been resolved.

GOV.UK Notify
Posted May 14, 2026 - 13:52 BST

Monitoring

We are aware of some degradation of SMS services relating to Lebara mobile starting at 11:00 BST. Sending and receiving of SMS, and receiving of delivery receipt may be affected or delayed.

GOV.UK Notify itself is fully operational. We will continue to monitor and post any updates here.
Posted May 14, 2026 - 11:41 BST
This incident affected: Text message sending, Text message delivery receipts, and Text message receiving.