Letter cancelling unavailable for some users

Incident Report for GOV.UK Notify

Resolved

This incident has been resolved.
Posted Apr 17, 2026 - 17:34 BST

Monitoring

We're monitoring any reports from users getting in touch via our support form - https://www.notifications.service.gov.uk/support.
Posted Apr 17, 2026 - 14:11 BST

Investigating

If you have sent any letters after 5:30pm yesterday 16 April up until 1:54pm today 17 April and you need to cancel any of them you'll not be able to do so by yourself as usual; please get in touch via our support form - https://www.notifications.service.gov.uk/support.
Posted Apr 17, 2026 - 14:01 BST
This incident affected: Letter sending.