Slow responses from the GOV.UK Notify API
Incident Report for GOV.UK Notify
Resolved
The Notify API's performance is back to normal and response times have been fast and stable since we terminated the long running query at 1:52pm BST. We anticipate no further errors or slow-down.

Sorry for the inconvenience to you and your users.

The GOV.UK Notify team
Posted Jun 01, 2023 - 16:39 BST
Monitoring
We identified a long-running query against one of our tables that was causing high load on the database.

The high load on the database resulted in slower responses from the API for all requests.

We have terminated the query and seen database load decrease and API response times come back down to normal.

We will continue to monitor for the next few hours, but we expect no further issues at this time.

The GOV.UK Notify team
Posted Jun 01, 2023 - 14:53 BST
Investigating
The Notify API is providing some slow responses at the moment. Requests are still being processed, but are taking longer to complete than usual.

We will provide a further update when we know more.

Thank you for your patience.

The GOV.UK Notify team
Posted Jun 01, 2023 - 13:41 BST
This incident affected: API.